using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\${[a-z]+\.[a-z]+\.[a-z]+\.|}";
string substitution = @"";
string input = @"""Patient:
${ss.patient.howard.firstName} ${ss.patient.howard.lastName}
Gender: ${ss.patient.howard.sex}
Birthdate: ${ss.patient.howard.dob}
${ss.patient.howard.addressLine1}
Phone: (801)546-4765""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}