const regex = /^\d{3}(?:$|\s)(?:([ACERV])(?!\1)|\s(?!$|\1))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{3}(?:$|\\s)(?:([ACERV])(?!\\1)|\\s(?!$|\\1))*$', 'gm')
const str = `123
123 A
123 A V
123 CER
123 V V
Invalid formats:
123A
123 AA
123 A `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}