using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S{1,}\s\d{1,}\s)(Etage:\d{1,}\s\w{1,}\s)(Raum:\d{1,})";
string input = @"Jägerallee 23 Etage:1 OG Raum:4114";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}