const regex = /(\S{1,}\s\d{1,}\s)(Etage:\d{1,}\s\w{1,}\s)(Raum:\d{1,})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S{1,}\\s\\d{1,}\\s)(Etage:\\d{1,}\\s\\w{1,}\\s)(Raum:\\d{1,})', 'i')
const str = `Jägerallee 23 Etage:1 OG Raum:4114`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}