$re = '/(\S{1,}\s\d{1,}\s)(Etage:\d{1,}\s\w{1,}\s)(Raum:\d{1,})/i';
$str = 'Jägerallee 23 Etage:1 OG Raum:4114';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);