re = /^(?!.*@(example1\.com|example2\.org|example3\.net)\b)(?:(?:To:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,})|(?:CC:[^<>,;]+(?:<[^<>]+>)?(?:,[^<>,;]+(?:<[^<>]+>)?){2,}))/m
str = 'To:jerry@example1.com,larry@example1.com,berry@example1.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end