#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^(join|j) https://discord\.gg/([A-Za-z0-9]+)$"
Local $sString = "join https://discord.gg/daze1313890DsqdjazhSHQKDHAZE"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")