const regex = /(?:\(?)([0-9]{2})(?:\)? ?)(9?[0-9]{4})(?:\-)?([0-9]{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\(?)([0-9]{2})(?:\\)? ?)(9?[0-9]{4})(?:\\-)?([0-9]{4})', 'g')
const str = `69992395568`;
const subst = `($1) $2-$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);