package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\B#\w+`)
var str = `This is a #hashtag, and this is #another one!
google.com#tag`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}