re = /\B#\w+/
str = 'This is a #hashtag, and this is #another one!
google.com#tag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end