re = /<data_[a-zA-z]{3} .*?>/
str = '<data_let пробел**какие угодно символы кроме >
<data_abc asasgfgag12414.*asfasf>
<data_ABC asgasg>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end