#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?=^\s*DETECTORES SELECCIONADOS HABILITADOS).{40}"
Local $sString = " DETECTORES SELECCIONADOS HABILITADOS EVENTO NUMERO 2423 EM 20:38 13-03-15 " & @CRLF & _
" RELES ISOLADOS EVENTO NUMERO 2496 EM 05:21 23-03-15 " & @CRLF & _
" EVACUAÇAO EVENTO NUMERO 2497 EM 14:49 23-03-15 " & @CRLF & _
" ALARME SILENCIADO EVENTO NUMERO 2498 EM 14:49 23-03-15 " & @CRLF & _
" ENTRADA DE ALTERAÇOES NIVEL ACESSO 02 EVENTO NUMERO 2499 EM 14:49 23-03-15 " & @CRLF & _
" SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2500 EM 14:49 23-03-15 " & @CRLF & _
" REPOSIÇAO GERAL REPOSIÇOES 0004 EVENTO NUMERO 2501 EM 14:50 23-03-15 " & @CRLF & _
"DEFEITO ZONA 023 DSP 094 L03 SIRENE Portaria DISPOSITIVO REMOVIDO EVENTO NUMERO 2502 EM 17:50 24-03-15 " & @CRLF & _
"FOGO 001 ZONA 011 DSP 033 L01 OPTICO Carrocel, ADM. Setor Qualidade EVENTO NUMERO 2503 EM 03:20 25-03-15 " & @CRLF & _
" SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2504 EM 03:25 25-03-15 " & @CRLF & _
" SAIDA SEM INTRODUÇAO DE ALTERAÇOES EVENTO NUMERO 2505 EM 03:26 25-03-15 " & @CRLF & _
" EVACUAÇAO EVENTO NUMERO 2506 EM 03:26 25-03-15 " & @CRLF & _
" RELES HABILITADOS EVENTO NUMERO 2507 EM 03:26 25-03-15 " & @CRLF & _
" EVACUAÇAO DESLIGADA EVENTO NUMERO 2508 EM 03:26 25-03-15 " & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")