re = /^[ \s\0\x0B]+|[ \s\0\x0B]+$/m
str = ' cat
|-- Usage Example --|
Javascript:
" Your string ".replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , \'\' );
function trim( str ){
return str.replace( /^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/g , \'\' );
}
PHP:
preg_replace( \'^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/\' , \'\' , " Your string " );
function trim( $str="" ){
return preg_replace( \'^[ \\s\\0\\x0B]+|[ \\s\\0\\x0B]+$/\' , \'\' , $str );
}
Output: "Your string"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end