#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(US|UK|FR)|(CA|NY|IA|TX|MI)|(\d+\/\d+)|\(((.+?)\s+([0-9]+))\)|([A-Z][a-z]{2,}|[A-Z]{3,})|(.*?)"
Local $sString = "US 7/70 MI Construction hrs." & @CRLF & _
"US IA Private hrs." & @CRLF & _
"US OIL 8/70 hrs. (Dec 2014)" & @CRLF & _
"UK 7/70 MI Construction hrs." & @CRLF & _
"UK IA Private hrs." & @CRLF & _
"UK OIL 8/70 hrs. (Dec 2014)" & @CRLF & _
"FR 7/70 MI Construction hrs." & @CRLF & _
"FR IA Private hrs." & @CRLF & _
"FR OIL 8/70 hrs. (Dec 2014)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")