# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(US|UK|FR)|(CA|NY|IA|TX|MI)|(\d+\/\d+)|\(((.+?)\s+([0-9]+))\)|([A-Z][a-z]{2,}|[A-Z]{3,})|(.*?)"
test_str = ("US 7/70 MI Construction hrs.\n"
"US IA Private hrs.\n"
"US OIL 8/70 hrs. (Dec 2014)\n"
"UK 7/70 MI Construction hrs.\n"
"UK IA Private hrs.\n"
"UK OIL 8/70 hrs. (Dec 2014)\n"
"FR 7/70 MI Construction hrs.\n"
"FR IA Private hrs.\n"
"FR OIL 8/70 hrs. (Dec 2014)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.