# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(((([a-zA-Z0-9]{2,255})+[/.]|([a-zA-Z0-9]{2,255})+[/_]|([a-zA-Z0-9]{2,255})+[/-])+[a-zA-Z0-9]{2,255})|[a-zA-Z0-9]{2,255})+@(((([a-zA-Z0-9]{2,255})+[/.]|([a-zA-Z0-9]{2,255})+[/_]|([a-zA-Z0-9]{2,255})+[/-])+[a-zA-Z0-9]{2,255})|[a-zA-Z0-9]{2,255})+\.[a-z]{2,64}"
test_str = ("valid.email@example.com\n"
"john.doe123@example.co.uk\n"
"alice_smith@company.org\n"
"user1234@emailprovider.net\n"
"test.email1234@email-domain.com\n"
"support@website.info\n"
"jane.doe@emailprovider.org\n"
"contact_us123@example.net\n"
"my.email123@email-provider.co\n\n\n"
"a@ce.ce\n"
"invalid.email@missingtld\n"
"john.doe@invaliddomain.c\n"
"spaces in@email.com\n"
"special!chars@email.com\n"
"noatemail.com\n"
"double..dots@email.com\n"
"@missingusername.com\n"
"user@inva@lid.com\n"
"missingatsigndomain.com")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.