re = /(((([a-zA-Z0-9]{2,255})+[\/.]|([a-zA-Z0-9]{2,255})+[\/_]|([a-zA-Z0-9]{2,255})+[\/-])+[a-zA-Z0-9]{2,255})|[a-zA-Z0-9]{2,255})+@(((([a-zA-Z0-9]{2,255})+[\/.]|([a-zA-Z0-9]{2,255})+[\/_]|([a-zA-Z0-9]{2,255})+[\/-])+[a-zA-Z0-9]{2,255})|[a-zA-Z0-9]{2,255})+\.[a-z]{2,64}/
str = 'valid.email@example.com
john.doe123@example.co.uk
alice_smith@company.org
user1234@emailprovider.net
test.email1234@email-domain.com
support@website.info
jane.doe@emailprovider.org
contact_us123@example.net
my.email123@email-provider.co
a@ce.ce
invalid.email@missingtld
john.doe@invaliddomain.c
spaces in@email.com
special!chars@email.com
noatemail.com
double..dots@email.com
@missingusername.com
user@inva@lid.com
missingatsigndomain.com'
# Print the match result
str.match(re) do |match|
puts match.to_s
end