#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\/([^_].*\.scss)$"
Local $sString = "sass" & @CRLF & _
"sass/index.scss" & @CRLF & _
"sass/_estructura.scss" & @CRLF & _
"sass/_tema.scss" & @CRLF & _
"sass/_texto.scss" & @CRLF & _
"sass/_fonts.scss" & @CRLF & _
"sass/juegos.scss"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")