// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\/([^_].*\.scss)$").unwrap();
let string = "sass
sass/index.scss
sass/_estructura.scss
sass/_tema.scss
sass/_texto.scss
sass/_fonts.scss
sass/juegos.scss";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}