$re = '/if*(((?!then).)*)/mi';
$str = 'return -(b+a)+math.pow(a,b)
b=b+1;a=a-1;return b+a
if r>0 and m==0 or (m % 10 == 5) then return 1*en else return 0 end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);