$re = '/(<\/?a\b(?:\s+[a-z]+="[^"]*")*[^>]*>)/isu';
$str = ' <a>foo</a> <a href="foo">foo</a> <a href="<foo>">foo</a> <a href="" title="">foo</a> <aa></aa> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);