// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?isu)(<\/?a\b(?:\s+[a-z]+="[^"]*")*[^>]*>)"#).unwrap();
let string = " <a>foo</a> <a href=\"foo\">foo</a> <a href=\"<foo>\">foo</a> <a href=\"\" title=\"\">foo</a> <aa></aa> ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}