#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(.*)style\(data-above-the-fold="true"\)[\s\S]*"
Local $sString = "DOCTYPE html" & @CRLF & _
"html" & @CRLF & _
" head" & @CRLF & _
" title gulp-gotohead" & @CRLF & _
" style." & @CRLF & _
" article {border:1px solid}" & @CRLF & _
" style(data-above-the-fold="true")." & @CRLF & _
" body {font-size:100%}" & @CRLF & _
" body{font-size:100%}" & @CRLF & _
" body.main{font-size:100%}" & @CRLF & _
" body, h1{font-size:100%}" & @CRLF & _
" body>h1{font-size:100%}" & @CRLF & _
" header {color:#333}" & @CRLF & _
" script(data-above-the-fold="true")." & @CRLF & _
" var head = Head();" & @CRLF & _
" head();" & @CRLF & _
" body (data-d="true")" & @CRLF & _
" h1 gulp-gotohead" & @CRLF & _
" p" & @CRLF & _
" span regex"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")