const regex = /^(\s*)style\(data-above-the-fold="true"\)\.\n(\1\s+.*\n)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\s*)style\\(data-above-the-fold="true"\\)\\.\\n(\\1\\s+.*\\n)*', 'gm')
const str = `DOCTYPE html
html
head
title gulp-gotohead
style.
article {border:1px solid}
style(data-above-the-fold="true").
body {font-size:100%}
body{font-size:100%}
body.main{font-size:100%}
body, h1{font-size:100%}
body>h1{font-size:100%}
header {color:#333}
script(data-above-the-fold="true").
var head = Head();
head();
body (data-d="true")
h1 gulp-gotohead
p
span regex`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}