const regex = /([1-9]{2}|50)-[0-9]{3,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([1-9]{2}|50)-[0-9]{3,4}$', 'gm')
const str = `11-184
11-0132
12-729
13-276
13-35
13-3573
14-453
15-743
16-2576
16-251
17-34567
17-345
18-730
19-137
19-3a61
50-947
50-2693`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}