import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[0]{1}[7]{1}[01245678]{1}[0-9]{7}$";
final String string = "0712912826\n"
+ "0700000000\n"
+ "0710000000\n"
+ "0721234567\n"
+ "0731234567\n"
+ "0791234567";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}