$re = '/\$[^\$]++\$/m';
$str = '1 [00:00:12.00 - 00:01:20.00] Hello there - I\'ve come to help you.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);