// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<a\s[^>]*href="https://site\.ru/[^>]*>(.*?)</a>"#).unwrap();
let string = "<a href=\"https://site.ru/*****>слово</a>
<a class=\"m\" href=\"https://site.ru/*****>слово</a>
<a href=\"https://site.ru/*****\" class=\"m\" >слово</a>";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}