using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([1-9]\d{5})(18|19|([23]\d))\d{2}((0[1-9])|10|11|12)([0-2][1-9]|10|20|30|31)(\d{3}[0-9Xx]))|(^[1-9]\d{5}\d{2}(0[1-9]|10|11|12)(([0-2][1-9])|10|20|30|31)\d{2})";
string substitution = @"$2*********$8";
string input = @" jkjk@abchi.comsdfds13544448888 16633331111
410581198807229059";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}