use strict;
my $str = 'Lorem ASPIRE dolor sit amet, consectetur adipiscing elit. ASPIRE finibus mauris quis tortor commodo, ut placerat sapien pellentesque. Interdum et malesuada ASPIRE ac ante ipsum primis in faucibus. Proin efficitur purus eu varius AB. Sed congue dui sit amet aliquet tempor. Praesent sit amet ABC velit, nec rhoncus elit. Curabitur eget magna elementum, porttitor metus tincidunt, semper turpis. Curabitur a ante tristique, hendrerit leo malesuada, mattis arcu. Fusce nec ultricies dolor, nec aliquet ASPIRE. Morbi tempor vel dolor sed varius. Vestibulum non ipsum ultrices, egestas nulla lobortis, fringilla nisi. Phasellus commodo tristique dolor eu dictum. Phasellus orci risus, dignissim eget tortor at, tincidunt ASPIRE est. Nunc eget tellus ut diam vestibulum laoreet sed ASPIRE odio.';
my $regex = qr/(?:\w+\W+){4}([A-Z]{3,})(?:\W+\w+){4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}