#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([_]{1,})$"
Local $sString = "_asd" & @CRLF & _
"a_" & @CRLF & _
"__" & @CRLF & _
"_asd_" & @CRLF & _
"a__" & @CRLF & _
"_" & @CRLF & _
"asd asd a __ asd asd " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")