use strict;
my $str = 'file:///home/pasta/pasta/img/intro-bg.jpg
http://www.google.com/m8/feeds/contacts/myemail%40gmail.com/base/nabb80191e23b7d9
https://regex101.com/r/mblcCW/1/
https://pt.stackoverflow.com/questions/249556/express%C3%A3o-regular-para-capturar-depois-da-%C3%BAltima-barra';
my $regex = qr/(?!\/)[^\/]+\/?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}