$re = '/^(.+?)(?:\.\((\d{4}\-\d{2}\-\d{2}\s)?([^\)]*)\))?(?:\.(.+))?$/m';
$str = 'O.(2008-08-27).Animation
Avatar 2 - la voie de l\'eau.(2022-12-14)
Prey.(2022-08-05 Disney+)
Star Wars- The Clone Wars.(2008-08-27).Animation
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);