#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\b"
Local $sString = "//1. support post-livraison" & @CRLF & _
" //2. support post livraison" & @CRLF & _
" //3. support client post livraison" & @CRLF & _
" //4. support client post-livraison" & @CRLF & _
" //5. post-livraison" & @CRLF & _
" //6. post livraison" & @CRLF & _
" //7. support client" & @CRLF & _
" //8. support post" & @CRLF & _
" //9. client post-livraison" & @CRLF & _
" //10. client post livraison" & @CRLF & _
" //11. support" & @CRLF & _
" //12. livraison"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")