package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(support post-livraison|support post livraison|support client post livraison|support client post-livraison|post-livraison|post livraison|support client|support post|client post-livraison|client post livraison|support|livraison)\b`)
var str = `//1. support post-livraison
//2. support post livraison
//3. support client post livraison
//4. support client post-livraison
//5. post-livraison
//6. post livraison
//7. support client
//8. support post
//9. client post-livraison
//10. client post livraison
//11. support
//12. livraison`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}