import re
regex = re.compile(r"<\w+>.*?<\/\w+>", flags=re.MULTILINE)
test_str = ("['<body>Welcome to our course! It would be an awesome experience</body>',\n"
" '<article>To be a data scientist, you need to have knowledge in statistics and mathematics</article>',\n"
" '<nav>About me Links Contact me!']")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")