# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\w\s]+/*special_char*/gm;t' <<< "$$ this is a .... text : ha
$%"