$re = '`[^\w\s]+`m';
$str = '$$ this is a .... text : ha
$%';
$subst = "*special_char*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;