#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\s) +|^ +(?=\s)| (?= +[\n\0])"
Local $sString = " .LW 30" & @CRLF & _
"Properly formatting a file where" & @CRLF & _
"there " & @CRLF & _
"is" & @CRLF & _
"" & @CRLF & _
" a smattering of white space throughout" & @CRLF & _
" really means eliminating that " & @CRLF & _
"extra" & @CRLF & _
" white " & @CRLF & _
" space " & @CRLF & _
"such that the result" & @CRLF & _
" looks neat " & @CRLF & _
" and" & @CRLF & _
" very" & @CRLF & _
" tidy. " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")