re = /(?<=\s) +|^ +(?=\s)| (?= +[\n\0])/
str = ' .LW 30
Properly formatting a file where
there
is
a smattering of white space throughout
really means eliminating that
extra
white
space
such that the result
looks neat
and
very
tidy.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end