import Foundation
let pattern = #"(?<=\s) +|^ +(?=\s)| (?= +[\n\0])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
.LW 30
Properly formatting a file where
there
is
a smattering of white space throughout
really means eliminating that
extra
white
space
such that the result
looks neat
and
very
tidy.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)