#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(http:\/\/example\.com\/.*?\/.*?\/.*?)\.png"
Local $sString = "bunch_of_text#http://example.com/images/XX/YY/filename.png#bunch_of_text%%more_text""http://example.com/2016/10/26001140/blah.png@@more_text"
Local $sSubst = "$1.jpg"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)