package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)951\d+`)
var str = `95168372685
95268372685
9518573
23456789
95199838995
95335363647
951123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}