#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[A-Za-z](.*)([A-Za-z]|([A-Za-z]{1}[0-9]))(.*?)\s"
Local $sString = "c:\ecpg\BL_Publish_Staging_CFCS_AP_COA_16\COA\fonts\glyphicons-halflings-regular.woff2 20150616 03:56:18 18028" & @CRLF & _
"" & @CRLF & _
"c:\\ecpg\\BL_Publish_Staging_CFCS_PSC_Outage_Notification_16\\images\\LOGO.JPG 20130104 06:16:36 4084" & @CRLF & _
"" & @CRLF & _
"c:\ecpg\myfolder\file with space.cfm 20160803 01:09:54 1574" & @CRLF & _
"" & @CRLF & _
"c:\ecpg\myfolder\no_space.cfm 20160803 01:09:54 1574" & @CRLF & _
"" & @CRLF & _
"c:\ecpg\BL_Publish_Staging_CFCS_PSC_Outage_Notification_16\add_service.cfm 20160803 01:09:54 1574" & @CRLF & _
"" & @CRLF & _
"c:\myfolder\.project 20170221 07:54:10 265" & @CRLF & _
"" & @CRLF & _
"c:\myfolder asdasdasd ASASASDAS 32423423 sadsd a1234 \.project123 20170221 07:54:10 265"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")