$re = '/(pattern1)(pattern2)?/m';
$str = 'pattern1
pattern1pattern2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);