use strict;
my $str = 'Matches containing some directory names,
but what about the oposite? having "good|big|aproved" directorys? and then hiding the others?
16x16
20x20
250x250
50x50
flobee
x
xx
abc/cdr
--> to hide >--
16x16/xxxx
/16x16/xxxx
path/16x16/xxxx
250x250/xxxx
/250x250/xxxx
good/16x16/xxxx
/good/16x16/xxxx
big/16x16/xxxx
/big/16x16/xxxx
--< to hide <--
good/xxxx
/good/xxxx
big/xxxx
/big/xxxx
/a/b/c/xxx.file
';
my $regex = qr/^(?!.*?(16x16|250x250|50x50))(?:\w+|.*)/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}