#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:"arrayKey1": (?<arrayKey1>[^"]+),[\n\t ]+"arrayKey2": "(?<arrayKey2>[^"]+)",[\n\t ]+"arrayKey3": "(?<arrayKey3>[^"]+)")(?:[\s\S]*)(?:"anotherKey": "(?<anotherKey>[^"]+)")"
Local $sString = "{" & @CRLF & _
" "key1": "value1"," & @CRLF & _
" "key2": "value2"," & @CRLF & _
" "key3": "value3"," & @CRLF & _
" "key4": [" & @CRLF & _
" {" & @CRLF & _
" "arrayKey1": 1," & @CRLF & _
" "arrayKey2": "something"," & @CRLF & _
" "arrayKey3": "somethingelse"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "arrayKey1": 2," & @CRLF & _
" "arrayKey2": "something2"," & @CRLF & _
" "arrayKey3": "somethingelse2"" & @CRLF & _
" }," & @CRLF & _
" {" & @CRLF & _
" "arrayKey1": 3," & @CRLF & _
" "arrayKey2": "something3"," & @CRLF & _
" "arrayKey3": "somethingelse3"" & @CRLF & _
" }" & @CRLF & _
" ]," & @CRLF & _
" "some very long text here": """ & @CRLF & _
" "anotherKey": "value"," & @CRLF & _
" "keylast": "valuelast"" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")