use strict;
my $str = 'PO 11-1111
PO-11-1111
PO# 11 1111
PO#11-1111
PO 111111';
my $regex = qr/^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}