// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^PO[\#\s-]\s?\d{2}[\s-]{0,1}\d{4}$").unwrap();
let string = "PO 11-1111
PO-11-1111
PO# 11 1111
PO#11-1111
PO 111111";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}