using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"LIST\d+ LIST\d+\R((?!$)\S*(?: +\S+)?(?:\R|\Z))*?(?:(?:(\S+) +(?:\S*\R(?1)*\S* +)?\2\b\R?)|(?:\S+ (\S+)\R(?1)*\3\b))(?1)*";
string input = @"LIST1 LIST2
item1 item2
item3 item4
item5 item6
LIST3 LIST4
item1 item2
item4
item2
LIST5 LIST6
item1 item3
item2 item4
item5 item2
LIST7 LIST8
item1 itemA
item2 itemB
item3 itemC
itemD
item3
itemE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}